Jump to content

I give up! 2003 won't start.


Chadwick
 Share

Recommended Posts

First time posting. I bought a barn find 2003 Banshee. Carbs were off so I rebuilt them and did the tors delete. Unplugged everything not needed. I seem to have spark but doesn't even attempt to fire even with starting fluid or a little fuel in the cylinder.  I don't know much about it other than it has a cool head and T6 exhaust. Any help would be greatly appreciated. Otherwise I'll be looking for a banshee mechanic in Omaha Ne. Ha!

Link to comment
Share on other sites

Choke crossover tube connected in the right spot? Make sure the slide move with the idle screws, zero them and as soon as they move go 3/4 to full turn. Pilots not plugged?

There’s very little to these shit boxes, it won’t be hard to figure out.

Link to comment
Share on other sites

Welp guys. Tried two things tonight. Re seated the ground on the rear and moved the pickup closer to the flywheel. A business cards worth. She fired right up!! Only thing now is left side seems a little cold coming out of the tailpipe but otherwise runs good. 

Link to comment
Share on other sites

So after it sat for less than a week I can't get it started again. It ran fine other than bogging a bit in second gear. Checked the pick up again and it hasn't moved. Re-seated the ground on the regulator again. Nothing. Any ideas?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...