Jump to content

xmarlboromanx

Members
  • Content Count

    16
  • Joined

  • Last visited

Community Reputation

1 Neutral

About xmarlboromanx

  • Rank
    HQ Noob
  • Birthday 09/21/1987

Profile Information

  • Gender
    Male
  • Location
    Freeland Pa

Previous Fields

  • My Banshee (optional)
    White/black 2000 banshee FMF fatty pipes and k&n Pro flow filter.TORS removal kit. Mikuni carb with 290 main 27.5 pilot.
  1. As the title says I need some stock upper a-arms for my 2000 banshee. My ball joints are shot. I don't have a lot of money, but I really want to ride. So let me know what you got for sale.. Thanks for your time!
  2. Turned out to be a combo of a bad Float needle and a very loose thin black wire that plugs into the coil.
  3. As the title says I need some stock upper a-arms for my 2000 banshee. My ball joints are shot. I don't have a lot of money, but I really want to ride. So let me know what you got for sale.. Thanks for your time!
  4. OK just went out with new plugs I see a blue spark coming from where the thin black wire plugs into the coil under the handle bars.. I know the other day part of the wire was showing so I put some E tape on it guess I didn't do a good job lol.. So I'm guessing that would be my problem?
  5. Maybe I'll go out now while its dark and see if I can see it arc.... And if I don't get this figured out I just might need some more rope....
  6. I tried all clip positions/cleaned the carb good. I'm starting to think my main is too big(290) I have a 250 jet just don't know if that's too lean. or it has something to do with my coil/spark plug wire cause I got shocked touching the cap. Cleaning the filter out now if this don't work it has to be that. Each cylinder has about 120-125 psi.. Wish there was someone close to me to help. It's getting warmer and this is frustrating...
  7. Well I'm in the process of cleaning the filter now, I don't see how it would need more air being a k&n? I don't know maybe your right. Took both carbs apart and cleaned them and synced again and it's still doing it..
  8. Got zapped pretty good when I touched the spark plug cap.
  9. seems to kick in faster and stronger with the lid off....does this mean I'm too big on the main?
  10. Slides are in the right way and I'm not leaking and trans fluid. How would I go about a leak down test? I'm thinking it has something to do with my carbs cause it runs great after I get past the bog... Also forgot to mention it smokes (regular white smoke)more out of "when looking at the back end" the right pipe, but only sometimes.Antifeeze is still full. It ran great till I changed the throttle cables. Guy have a twist throttle on it and I changed to to a thumb throttle and also he had 250 mains in it and it was too lean for the cold weather were having.
  11. Well I don't no what to do anymore, I think I tried everything. When I'm rolling down a path and hit the throttle its bogs down almost like it's sucking in too much air and as soon as power band kicks in "kinda have to play with the throttle" hang on cause it hits strong and hard all the way to top. Now I checked for leaks in the boots, reeds look ok and the carbs are in sync close as I could get them. It has a k&n pro flow filter with a closed box, FmF fatty pipe and silencer. TORS removal (Mikuni) and as far as I could tell the engine is stock. 290 mains, 27.5 pilots and stock need
×
×
  • Create New...