Jump to content
BansheeUSA

ATTENTION WHAT COULD POSSIBLY BE WRONG

Recommended Posts

Hey I’ve just got my banshee back it is now a 4mil and I’m having problems with power. YFZ 450’s are problems for me and idk why. When dragging from dig in dirt I can leave quicker but they gain on me, which I know should not be happening. Any advice on this. 
 

4 mil long rod 

795 wiseco pistons

stock gearing

34 mm carbs

cpi Pipes

cool head

Machines domes. 

Share this post


Link to post
Share on other sites

Well I don’t know much about 4 mils but I would assume your pipes are using a low end rpm pipe meant for trail riding. I have t5 pipes on my bike and the low end responsiveness is bad but in the high rpms the bike takes off and pulls hard. lower end rpm pipes almost always get the launch on people but they don’t really have much top end power which is why they are great trail pipes but suffer when drag racing since the bike doesn’t get much top speed since it doesn’t pull very hard at a higher rpms. 

Share this post


Link to post
Share on other sites
Hey I’ve just got my banshee back it is now a 4mil and I’m having problems with power. YFZ 450’s are problems for me and idk why. When dragging from dig in dirt I can leave quicker but they gain on me, which I know should not be happening. Any advice on this. 
 
4 mil long rod 
795 wiseco pistons
stock gearing
34 mm carbs
cpi Pipes
cool head
Machines domes. 
Who ported it

Sent from my LM-V350 using Tapatalk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×